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Topic 1: Welcome 

Welcome to this tutorial on Using QGIS for KBA Identification and Delineation. This tutorial 
is designed to provide new users with a practical task-focused guide to using a 
Geographic Information System (GIS) for KBA identification and delineation.  

This tutorial is not a comprehensive GIS primer. There are many excellent GIS training 
resources available online, designed for various levels of experience and learning styles 
— we encourage you to check those out. 

We chose to focus on QGIS for this tutorial as it provides the functionality needed for 
KBA identification and delineation, is freely available, and widely used in the 
conservation community. KBA Proposers are welcome to use any other GIS software that 
meets their needs, with the proviso that final KBA boundaries and spatial data on the 
distribution of trigger biodiversity elements must be submitted as ESRI shapefiles. 

Please see the KBA Standard, the KBA Guidelines, the KBA Proposal Process guidance 
and the KBA online training course for general guidance on KBA identification, 
delineation, documentation and mapping. This tutorial is a complementary resource, 
focused on the GIS tasks commonly used in KBA identification and delineation, not a 
substitute for the KBA Standard or KBA Guidelines. 

Learning objectives 

By following the steps in this tutorial you will be able to: 
● Understand key concepts and terms used in GIS 
● Install QGIS on your computer 
● Set up a new QGIS project  
● Add high-resolution satellite imagery as a base map 
● Add national borders and boundaries of existing KBAs and protected areas 
● Merge several spatial layers into a single spatial layer 
● Download locality data from the IUCN Red List and add to a project as a spatial layer 
● Install the GBIF plugin and add GBIF occurrence data to a project 
● Download a range polygon from the IUCN Red List and add it to a project as a spatial 

layer 
● Download an ecosystem distribution map from the Red List of Ecosystems  
● Digitise a new polygon on-screen and create a new spatial layer 
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● Adjust or refine an existing polygon on-screen 
● Dissolve multiple features into a single feature 
● Calculate the area of a polygon feature and store it in the attribute table 
● Intersect a range or extent polygon with a site polygon to calculate the area of 

biodiversity element in a proposed site 
● Add attribute data to a spatial layer and edit attribute data 
● Export a spatial layer using a standard template for inclusion in a KBA proposal 

Important warning and recommendation 

Some KBA and species range polygons have incorrect projection metadata, resulting in 
polygons that are spatially offset from their true location (as in the examples below, for a 
KBA in the left panel and a species range map in the right panel). This can lead to 
significant errors in estimates of the proportion of a species’ population size found at a 
site or the extent of an ecosystem type at a site. It is therefore strongly recommended that 
KBA Proposers review all imported KBA or range shapefiles carefully by overlaying 
polygons on high-resolution satellite imagery before conducting KBA assessments.  

If you detect an apparent projection error, please alert your KBA National Coordination 
Group (NCG) or KBA Regional Focal Point (RFP). The KBA NCG or RFP can address any 
projection errors in KBA shapefiles; the KBA RFP can request that the IUCN Red List Unit 
address any errors in IUCN Red List range maps.  

You can find more information on the importance of projection in Topic 2.  
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Topic 2: The importance of projection 

In this topic, we’ll cover some useful background information on the importance of 
projection and explain the difference between geographic and projected coordinate 
reference systems.  

This is the only theoretical topic in the tutorial — it is essential background for 
successfully using GIS in KBA identification and delineation. It draws heavily on material 
originally developed by USFWS. 

The Earth is not a sphere 

While we often think of the Earth as a sphere, the circumference at the Equator is actually 
slightly greater than the circumference at the poles. This shape is represented in GIS by 
an ellipsoid, i.e. a smooth sphere that has been vertically compressed.  

 

 

 

Various models of the true shape of the Earth have been developed, including the widely 
used WGS 84 ellipsoid that is optimised for global use. The precise location of a point 
on the surface of an ellipsoid can be described using a standard reference system or 
datum. The standard datum for the WGS 84 ellipsoid is called WGS 84. Other 
examples of datums include NAD27 and NAD83, both based on ellipsoids optimised 
for North America. 

The Earth represented as an ellipsoid (scale is 
greatly exaggerated). Source: USFWS 
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Geographic Coordinate Reference Systems (CRS) 

The coordinates (e.g., latitude and longitude) of a particular point on the Earth’s surface 
vary, depending on the ellipsoid and datum used. The position of a point on the 
Earth’s surface can be simply and adequately described (or “georeferenced”) by 
recording the coordinates plus datum. This is a geographic coordinate reference 
system (CRS). The geographic CRS of latitude and longitude (decimal degrees) 
combined with the WGS 84 datum is referenced by the code “EPSG:4326” in QGIS and 
“GCS_WGS_1984” in ArcGIS. 

Global Positioning Systems (GPS) commonly use EPSG:4326 by default, but this can be 
modified, so that your GPS returns data in a different CRS. For this reason, it is essential 
that you document the CRS of your GPS when recording occurrence data. If the datum is 
unknown, your GIS may assign the wrong datum and position data points in the wrong 
place. 

Projected Coordinate Reference Systems (CRS) 

To represent the near-spherical surface of the Earth on a flat surface, such as a map or a 
screen, a map projection is needed. Map projections mathematically stretch and 
transform the curved surface to make it lie flat for easier representation.  

Map projections are also used to reproject spatial data layers from a 3-dimensional 
geographic coordinate system to a 2-dimensional flat (or “planimetric”) surface 
when calculating the area of a site, a species’ range or an ecosystem’s extent.  

Many different projections have been developed, optimised for different purposes. 
For example, the Mercator projection prioritises accuracy of direction and is widely 
used in navigation. In contrast, the Mollweide and World Cylindrical Equal-Area 
projections prioritise accuracy of area and can be used to compare the size of species’ 
ranges or sites around the globe.  
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For the purposes of KBA assessment, the ability to measure area accurately and 
consistently anywhere on the globe is a high priority. The KBA Guidelines therefore 
specify that area should be calculated in the World Cylindrical Equal-Area projection 
(specifically “+proj=cea +lat_ts=0 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m 

Mercator projection – directions are accurate, but 
area is greatly distorted. Source: USFWS 

 

Mollweide projection – areas are accurate, but 
direction is distorted. Source: USFWS 
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+no_defs”). This projected coordinate reference system can be referenced by 
the code “ESRI: 54034” in QGIS and “World_Cylindrical_Equal_Area” in ArcGIS.  

As we’ll see in the Polar Bear experiment below, it’s important to specify the projected 
CRS when calculating area if we want accurate and consistent results. If we don’t tell the 
GIS exactly how we want to convert our 3-dimensional geographic data to a 2-
dimensional planimetric surface for the purposes of calculating area, the GIS may use a 
default method and give results that are inconsistent with other GIS, or it may simply 
produce an error message. 

Technical Box: Projections for area measurement 

Area measurements should be performed using a Cylindrical Equal Area projection, 
i.e.: 

CRS: “+proj=cea +lat_ts=0 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m 
+no_defs” 
 
QGIS name: “ESRI:54034” 
 
ArcGIS name: “World_Cylindrical_Equal_Area”  

Topic summary 

Well done — you’ve completed the topic on the importance of projection.  

In the next topic, we’ll install QGIS and set up a new QGIS project .  
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Topic 3: Installing QGIS and setting up a new QGIS project 

This topic is provided for new users of QGIS. We’ll provide guidance on how to install 
QGIS on your computer and set up a new QGIS project. 

Install QGIS on your computer 

QGIS is a freely available GIS software package that can be run on a desktop computer 
(MacOS, Windows, or Linux). 

QGIS can be downloaded here. For new users, we recommend you use the “most stable” 
all-in-one installer for your operating system. 

You can find more detailed guidance on how to install and use QGIS here. 

When your installation is complete, navigate to the application and open QGIS. 

You’ll see a notice at the bottom of your QGIS page whenever a new version is available. 

Set general options 

Set the default Coordinate Reference System (CRS) for use in new projects: 

Click on Settings > Options  

Under CRS for Projects, check the option for Use a default CRS and 
make sure the box says EPSG:4326 – WGS 84. 

Click on OK 
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If you like, you can also change your general settings to work in kilometers rather than 
meters. 

Click on Settings > Options > Map Tools  

For Preferred distance units, select Kilometers 

For Preferred area units, select Square Kilometers 

 

Set up a new QGIS project 

To set up a new QGIS project, go to the menu bar at the top of your QGIS page. 
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Select Project > new 

You’ll see a new blank project. 

If you check the lower-right of your QGIS project page, the CRS should be 
“EPSG:4326”. 

Save the project 

We recommend that you save your QGIS project regularly, so that you don’t need to 
repeat steps every time you work on a similar project. 

We also recommend that you keep all your spatial data in a single spatial data 

folder with subfolders added as needed. 

Click on the   button to save the project with an appropriate name in your 
QGIS folder. 

Open a project 

To open an existing project 

Select Project > Open or Project > Open Recent 

Topic summary 

Well done — you’ve completed the topic on setting up a new QGIS project.  

We recommend you Save your project now. 

In the next topic, we’ll add some base maps to your QGIS project.  
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Topic 4: Adding base maps to your QGIS project 

When delineating terrestrial, freshwater or coastal marine KBAs in a GIS, we strongly 
recommend that you use high-resolution satellite imagery as your background layer as 
this can help identify areas where the boundary needs to be refined.  

In this topic, we’ll show you how to add base maps to your QGIS project, together 
with other useful layers, such as national borders, boundaries of existing KBAs and 
projected areas. We’ll also show you how to implement some related tasks such as 
merging several spatial layers into a single layer and selecting features (e.g., KBAs) by 
attributes (e.g., name).   

Load ESRI high-resolution satellite imagery into QGIS 

Here, we’ll walk you through the process of adding high-resolution satellite imagery 
from the ESRI Living Atlas website. This is the base map we’ll use throughout this 
tutorial. Later, we’ll show you where to find additional base maps that might be useful 
for delineating KBAs. 

From the main ESRI Living Atlas webpage, click on Browse and Base 
maps. 

Click on World Imagery. 

In the bottom right of the World Imagery page, you’ll see a link for the URL of 
this map server layer. Copy this. 

In the QGIS menu bar, select Layer > Data Source Manager > ArcGIS 
Map Server. 

Then choose to create a New connection and complete the details for the ArcGIS 
Map Server Layer. In this case enter a Name (e.g., “Living Atlas – World Imagery”) 
and paste in the URL that you copied from the ESRI Living Atlas webpage 

Click OK to save the new connection 

Note. You’ll only have to do this once. This layer will now be available to you in QGIS 
whenever you want to use it as a base map. 
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Add ESRI high-resolution satellite imagery as a base map to your project 

Next, you’ll want to add the satellite imagery as a base map to your project. 

In the QGIS menu bar, select Layer > Data Source Manager > ArcGIS 
Map Service and select the base map that you just saved 

Click Connect and select “World Imagery” 

Click Add and the map server layer will be added to your QGIS project as the 
base map 

Your QGIS project page should now look similar to the image below (right-click on 
“World Imagery” and select Zoom to Layer if the base map doesn’t fill your page): 

 

Check your project projection 

Check again that the lower-right of your QGIS project page says “EPSG:4326”. The 
World Imagery layer is in a projected CRS (a pseudo-Mercator projection), but is 
displayed in the specified geographic CRS based on your QGIS project settings.  

You can explore different projections by selecting Project > Properties > CRS: 
● if you copy-paste “EPSG: 3857” into the Filter box, highlight “WGS 84/ Pseudo-

Mercator” in the box below, and then click Apply and OK, you’ll see that the base map 
has been transformed and Greenland is now about the same size as Africa; 

● if you copy-paste “ESRI: 54034” into the Filter box, highlight 
“World_Cylindrical_Equal_Area” in the box below, and then click Apply and OK, 
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you’ll see that the base map has been transformed again and Africa is now much 
larger than Greenland. 

In reality, Africa is approximately 30 million km2, whereas Greenland is approximately 2 
million km2, so you can see that the World Cylindrical Equal-Area projection is more 
appropriate for estimating and comparing the size of species’ ranges and sites around the 
globe. 

Remember to switch back to EPSG:4326 when you’ve finished experimenting. 

We recommend you Save your project now. 

Add national borders 

The Database for Global Administrative Areas (GADM) is a good source for spatial data 
on administrative boundaries. We’ll use Mozambique for the purposes of demonstration 
throughout this tutorial. 

From the GADM country page, select your country in the drop down box, and 
then select shapefile to download the shapefile as a zipfile 

Navigate to the downloaded zipfile in your downloads folder, unzip it, and copy 
all the files to your spatial data folder 

To add the new country spatial data layer to your QGIS project: 

In the QGIS menu bar, select Layer > Add Layer > Add Vector Layer, 
click on the … at the right of the Vector Datasets box and then navigate to your 
spatial data folder 

Select the “gadm .. “ file with “0.shp” at the end (e.g., gadm36_MOZ_0.shp”) and 
click Open 

Click Add then Close 

On the left of your QGIS project page, you’ll see a list of the spatial data layers, 
right-click on your new country layer and select Zoom to Layer 

Note that the GADM files with higher numbers represent lower-level administrative 
boundaries. You can follow a similar process to add those to your QGIS project if they 
might be useful. 
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If you choose to use a different shapefile (e.g., the official shapefile for your country’s 
national boundaries), follow the same process above but select the appropriate “.shp” 
file. 

To switch from a filled polygon to an outline: 

Click again on your country layer and then click on the  button above-
left to open the Layer Styling Panel 

Select one of the outline options (e.g., the pink square — you may need to scroll 
down) and then click Apply 

Close the Layer Styling Panel by clicking on the x in the upper-right 

Your QGIS project page may now look similar to this: 

 

If you want to zoom in to check how well the country borders align with natural features:  

Select the  button in the main toolbar and then select the area on the map 
where you want to focus 
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To move the area in view without changing the zoom level, select the  button 
in the main toolbar and then use your mouse to pan around the map 

To switch between displaying and not displaying a spatial data layer, check or 
uncheck the box next to the layer in the Layers Panel on the left 

For example, the image below shows how the northeastern border of Mozambique, as 
represented in the GADM shapefile, follows the River Rovuma and the coastline.  

 

We recommend you Save your project now. 

Import existing KBAs 

Request KBA spatial data for your country from the KBA website. When you receive 
them, save the files in your spatial data folder. 

To add the global KBAs spatial data layer to your QGIS project: 

In the QGIS menu bar, select Layer > Add Layer > Add Vector Layer, 
click on the … at the right of the Vector Datasets box and then navigate to your 
spatial data folder 

Select the “KBAsGlobal … POL.shp” and click Open then Add 
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Click on the … again, then select “KBAsGlobal …PNT.shp” (if it exists) then click 
Open then Add then Close 

Note. You’ll only have a “KBAsGlobal …PNT.shp” if some of the KBAs in your country 
are denoted by points rather than polygons. 

If you want to identify a polygon: 

Make sure the relevant spatial data layer is highlighted in the left Layer 
Panel 

Click on the  button in the main toolbar to Identify Features and then 
click on the polygon in question 

A table will pop up showing the attribute data for the selected feature; click on 
the x to close 

You can follow the instructions above to change the Layer Styling (hint: click on 
). If you choose a turquoise fill and 50% opacity, your QGIS project will now look 
similar to the image below:  
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We recommend you Save your project now. 

Import existing protected areas 

Run a Google search for protectedplanet.net and your country name. (We’ll use 
Mozambique’s protected areas in the examples below so you may want to download 
those to follow along.) 

Download the relevant dataset by following the relevant on-site instructions, and 
selecting SHP 

Navigate to the downloaded zipfile in your downloads folder, unzip everything, 
and copy all the files to your spatial data folder  

This dataset is generally packaged as 3 separate polygon shapefiles.  

In QGIS, follow the process above to add each of the 3 polygon shapefiles to your 
QGIS project (hint: start by selecting Layer > Add Layer > Add Vector 
Layer; click Open and Add for each layer, then Close when you’re done) 
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Merge several spatial layers into a single layer 

You can choose to merge these 3 shapefiles (or layers) into a single layer: 

In the QGIS menu bar, select Vector > Data management Tools > Merge 
Vector Layers 

Click on … next to the Input Layers box and check the 3 folders containing 
your 3 shapefiles (e.g., named “WDPBA_WDOECM…”), then click OK 

Under Destination CRS, select EPSG:4326 – WGS 84 

Click on … next to the Merged box, select Save to File and then save your new 
merged shapefile in your spatial data folder, then click OK 

Finally click Run at the lower-right 

Your new shapefile will be added to your QGIS project; you can right-click on 
the old “WDPBA_WDOECM…” files and select Remove Layer to remove from 
them from your QGIS project; the files will be removed from display, not 
deleted 

You may also want to move the KBA layer above the WDPA layer in the Layers 
Panel, so that KBAs are superimposed on protected areas 

Repeat this process for point data if necessary. 

Follow the instructions above to change the Layer Styling (hint: click on ). If you 
choose a green fill and 50% opacity, your QGIS project will now look like the image 
below: 
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We recommend you Save your project now. 

Select features by attribute 

It is often useful to select one or more features from a set of features in a spatial layer. 
Here, we’ll demonstrate one way to do this, but QGIS provides several different options. 

In the Layers Panel at the left of your QGIS project, right-click on your merged 

protected area layer and select Open Attribute Table (or click on the 
button in the toolbar) 

Click on the  button at the top to Select/filter features using form 



19 

At the box labelled NAME, type “Chimanimani” 

At the lower-right, click on the  button; 2 features should now be 
selected, both named “Chimanimani”, corresponding to the Chimanimani 
National Park and its buffer zone 

Close the Attribute Table and you’ll see the selected features highlighted in bright 
yellow — you can right-click on your merged protected area layer and select Zoom to 
Selection to zoom in. 

Sometimes it’s useful to save selected features as a new shapefile: 

Right-click again on your merged protected area layer and select Export > Save 
Selected Features As … 

Click on the … at the right of the File name box and then navigate to your 
spatial data folder; save the layer with a suitable name (e.g., 
“Chimanimani”); click save 

We recommend that you keep the data layer in its original geographic CRS at this 
stage; the CRS box should say EPSG:4326 – WGS 84 

Click ok 

Your new shapefile will now be listed as a spatial layer in the Layers Panel 

Follow the instructions above to change the Layer Styling. If you choose a blue fill 
and 50% opacity, your QGIS project will now look similar to the image below. (We 
have unchecked the merged WDPA layer in the Layers Panel and changed the Layer 
Styling of the KBA layer to a turquoise outline to show the recently confirmed 
Chimanimani KBA based on the Chimanimani National Park and its buffer zone.) 
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Topic summary 

Well done — you’ve completed the topic on setting high-resolution satellite imagery as a 
base map for your project and on importing spatial data on existing KBAs and protected 
areas.  

We recommend you Save your project now. 

In the next topic, we’ll add some occurrence data to your project.  
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Topic 5: Working with species occurrence data 

In this topic, we’ll show you how to download occurrence data from the IUCN Red List 
and add it to your QGIS project as a spatial layer and how to import occurrence data from 
the Global Biodiversity Information Facility (GBIF). Even if you do not plan to use 
number of localities as an assessment parameter, recent and reliable occurrence data can 
be useful in providing confirmation of presence. 

In addition, we’ll show you how to count the number of points (e.g., occurrences) in a 
polygon, although we note that it is often better to estimate the number of localities in a 
proposed site visually, in consultation with experts. 

Download occurrence data from the IUCN Red list and add to a project as a 
spatial layer 

Many plant species that have been assessed for the IUCN Red List have occurrence data 
and no range map. For the purposes of demonstration, we’ll look at the occurrence data 
for Aloe plowesii (VU), a geographically restricted species confined to the rocky grasslands 
of the central Chimanimani Range on the border of Zimbabwe and Mozambique. 

Go the IUCN Red List and search for “Aloe plowesii”, click on the download button 
in the upper-right, and select Range data – Points (CSV) and complete the 
data request form. You may need to create an account first 

Navigate to the downloaded zipfile in your downloads folder, unzip everything, 
and copy all the files to your spatial data folder — we recommend you 
save the data to a subfolder named “Aloe_plowesii” or similar. 

In the QGIS menu bar, select Layer > Add Layer > Add Delimited Text 
Layer, click on the … at the right of the File name box and then navigate to the 
relevant species subfolder in your spatial data folder 

Select the “points_data.csv“ file and click Open 

Note that the section on Geometry Definition should have Point 
Coordinates checked, the X field should be “longitude”, the Y field should 
be “latitude”, and the Geometry CRS should say “EPSG:4326 – WGS 84” 

Click Add then Close 
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In the Layers Panel on the left of your QGIS project page, you’ll see a list of 
the spatial data layers, including a new layer called “points_data”. This is not very 
descriptive, so you can rename the layer in your QGIS project by right-clicking 
on the layer and selecting Rename Layer (e.g., as “Aloe_plowesii”); this is just 
cosmetic — it does not change the name of the underlying file) 

You can change the Layer Styling just as you did for polygons. If you choose 
yellow and increase the size to “3”, then Zoom to Layer your QGIS project 
will now look like the image below. (The pink line represents the border between 
Zimbabwe to the west and Mozambique to the east.)  

 

If you check the IUCN Red List account for Aloe plowesii, you’ll see that 2 threat-defined 
locations have been identified from a total of 8 collections. The Mozambique KBA 
Secretariat reviewed this information in consultation with relevant species experts and 
determined that each of these locations likely represents a discrete population for the 
purposes of KBA identification: one in Mozambique (represented by 3 georeferenced 
occurrences in the spatial data table) and one over the border in Zimbabwe (represented 
by 2 georeferenced occurrences in the spatial data table).  

If you click on the  button in the main toolbar to Identify Features and then 
click on a point, you’ll see information about that particular occurrence, including the 
collection date (i.e. event_year). 
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Count the number of occurrences in a polygon 

Please review the KBA Guidelines and consult with species experts before using number 
of localities as an assessment parameter. QGIS includes functionality to count the number 
of points in a polygon feature, but, given that one discrete population may be represented 
by multiple points, it is often better to estimate the number of localities in a proposed site 
visually. (Note that it’s important to involve species experts in the process of identifying 
discrete populations from occurrence data as they will have knowledge of the species’ 
dispersal range. Also, some known occurrences may not be included in the spatial data 
table.) 

For example, if we wanted to estimate the number of localities of Aloe plowesii in the 
Chimanimani KBA, we would overlay the points on the polygon, right-click on the points 
layer and select Zoom to Layer. In the image below, you can see clearly that all the 
georeferenced occurrences in Mozambique (representing a single locality according to 
relevant experts) fall within the Chimanimani KBA (we have zoomed out so that you can 
see the whole KBA).  
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As a final step, we should check whether the occurrence data can be used to confirm 
recent presence of the species in the KBA. Here, we’ll demonstrate one way to do this, 
but QGIS provides several different options. 

In the main toolbar, click on the  button to select Select Feature(s) and 
then draw a box that encompasses all the points in the KBA 

Now open the Attribute Table for the occurrence data layer (hint: click on 

) and you’ll see the 3 points in the KBA highlighted 

If necessary, click on the  button at the lower-right to Switch to table 
view — you can then easily see the event_year for each of the selected points.  

In this case, all 3 georeferenced occurrences from the Chimanimani KBA were collected 
in 2014 — this information can be used to confirm the recent presence of the species in 
the KBA. 

Import occurrence data from the Global Biodiversity Information Facility (GBIF) 

There is a plugin for retrieving occurrence data from the Global Biodiversity Information 
Facility (GBIF) and importing it directly into QGIS. GBIF data may contain errors, but 
datasets provided by museums and recognised experts are often useful, especially for 
species that do not yet have an IUCN Red List account.  

In the QGIS menu bar, select Plugins > Manage and install plugins. In 
the left panel, click All and in the search box, type “GBIF occurrences”. Select 
GBIF Occurrences and click on Install Plugin. Once the plugin is installed, 
click on Close 

Once the GBIF Plugin is installed, click on the  button to open the GBIF 
Occurrences window. Enter the name of the species you wish to search for (e.g., 
“Nadzikambia baylissi”, which occurs in Mozambique) and click on Load 
occurrences 
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The occurrence data for the species will show up in your Layers Panel. In this 

case, there is a single occurrence. If you open the Attribute Table, , you’ll 
see that 4 specimens were collected in 2009 by Bill Branch (Professor W. R. Branch 
of the Port Elizabeth Museum in South Africa). 

This article provides some more information about the discovery of the Mount Mabu 
Chameleon (N. baylissi). The species is restricted to the forested slopes of Mount Mabu, 
as indicated by the species’ range map in the IUCN Red List account. It is a trigger species 
for the Mount Mabu KBA. In the image below, you can see how the species’ range (blue 
dotted outline) encompasses the forested area, extending slightly beyond the boundaries 
of the KBA (turquoise outline). The GBIF occurrence data collected in 2009 (red point) 
can be used to confirm the species’ recent presence in the KBA.  

 

Topic summary 

Well done — you’ve completed the topic on working with occurrence data.  

We recommend you Save your project now. 
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In the next topic, we’ll add some range maps to your project.  
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Topic 6: Working with species range polygons  

In this topic, we’ll switch from point data to polygon data. We’ll show you how to 
download a range polygon from the IUCN Red List and add it to your QGIS project 
as a spatial layer. We’ll also introduce the coding system used to distinguish different 
types of range polygon. It is essential that you check these codes to confirm that you are 
using the appropriate polygons when estimating range. For example, you should only 
use range polygons coded as “Extant” or “Probably Extant”. 

Download a range polygon from the IUCN Red List and add it to a project as a 
spatial layer 

For many species, range maps can be downloaded from the IUCN Red List account. 
IUCN range shapefiles often comprise multiple features (i.e. individual polygons or 
groups of polygons), each coded in terms of Presence, Origin and Season. 

For non-migratory species, the KBA Guidelines specify that KBA Proposers should use 
polygons coded as follows: 
● Presence = 1 (Extant) and 2 (Probably Extant); 
● Origin = 1 (Native) and 2 (Reintroduced) and 6 (Assisted Colonisation); and  
● any Season code (see below for migratory species). 

For migratory species that have distinct breeding and non-breeding ranges identified in 
IUCN Red List range maps, breeding and non-breeding ranges will typically be assessed 
separately: 
● KBA Proposers should use the area of the range coded as follows for the breeding 

range: 
o Presence = 1 (Extant) and 2 (Probably Extant); 
o Origin = 1 (Native) and 2 (Reintroduced) and 6 (Assisted Colonisation); and  
o Seasonality = 1 (Resident) and 2 (Breeding Season) and 5 (Seasonal Occurrence 

Uncertain).  
● KBA Proposers should use the area of the range coded as follows for the non-breeding 

range: 
o Presence = 1 (Extant) and 2 (Probably Extant); 
o Origin = 1 (Native) and 2 (Reintroduced) and 6 (Assisted Colonisation); and  
o Seasonality = 1 (Resident) and 3 (Non-breeding Season) and 5 (Seasonal 

Occurrence Uncertain).  
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Let’s consider a specific example, the Whooping Crane (Grus americana, EN): 

Go to the IUCN Red List and search for “Whooping Crane”, click on the 
download button at the upper-right, and select Range data – Polygons 
(SHP)  

Navigate to the downloaded zipfile in your downloads folder, unzip it, and copy 
all the files to your spatial data folder — we recommend you save the data 
to a subfolder named “Grus_americana” or similar. 

In the QGIS menu bar, select Layer > Add Layer > Add Vector Layer, 
click on the … at the right of the Vector Datasets box and then navigate to the 
relevant species subfolder in your spatial data folder 

Select the “data_0.shp” file and click Open 

Click Add then Close 

The new layer is called “data_0”, which is not very descriptive, so you can rename 
the layer in your project by right-clicking on the layer and selecting Rename 
Layer (e.g., as “whooping_crane”); this is just cosmetic — it does not change the 
name of the underlying file) 

Right-click on the Whooping Crane layer again and select Open Attribute 

Table (or highlight the layer in the Layers Panel and click on the  button 
in the toolbar) 

The panel on the left indicates that there are four separate “features” (i.e. polygons 
or groups of polygons); highlight each one in turn and check how they differ in 
terms of Presence, Origin and Season — each polygon is coded Presence = 1 
(i.e. the species is considered Extant throughout the mapped range); and Origin = 
1 (i.e. the species is considered Native throughout the mapped range), but Season 
is coded 1, 2, 3, or 4. 

If you like, you can click on the  button to Dock Attribute Table, which 
will allow you to select different polygons in the Attribute Table and see their 
spatial extent in your QGIS Project simultaneously 
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Let’s imagine we want to assess possible KBAs for the Whooping Crane in its breeding 
range only. Following the KBA Guidelines, we want to select Seasonal = 1 (Resident) and 
2 (Breeding Season) only: 

With a single species and just 4 polygons, the simplest method is to highlight the 
relevant polygons (i.e. those coded Seasonal=1, or Seasonal=2), using the shift key 
to highlight multiple rows — you’ll see the 2 small polygons in the northwest and 
southeast of the range highlighted in bright yellow on your map 

If you want to save this as a new shapefile, right-click on the Whooping Crane 
layer, select Save Selected Features As ..., then save the selected features 
in your spatial data folder under a new name (e.g., 
“Grus_americana_breeding”) 

You can repeat this process to select the non-breeding range.  

Click on the  button to Deselect all features from the current 
active layer 

Select polygons coded Seasonal=1, or Seasonal=3. If you want to select multiple 

polygons that are non-adjacent in the table, click the  button at the lower-right 
to Switch to form view then check the relevant boxes. 

The non-breeding range comprises 2 small polygons in the south of the range. The 
migration corridor or passage range (Seasonal = 4) is not included in either the breeding 
or non-breeding range. 

Remember that, for species that have been extirpated from part of their range or 
introduced for non-conservation purposes outside their native range, you only want to 
include polygons coded Presence = 1 or 2 and Origin = 1, 2 or 6. 

In the image below, the passage range is shown in pale yellow, the breeding range in 
purple, and the non-breeding range in red hatch. 
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We’ll not return to the Whooping Crane for a while, so you can tidy up your Layers 
Panel by right-clicking and selecting Remove Layer. 

Topic summary 

Well done — you’ve completed the topic on working with species range polygons. 

We recommend you Save your project now. 

In the next topic, we’ll look at how to calculate area and values of area-based parameters. 
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Topic 7: Calculating area and area-based assessment 
parameters 

In many cases, accurate estimation of area-based parameters (e.g., species’ range or 
ecosystem extent) is essential for assessing whether a site qualifies as a KBA. Area 
calculations for the same polygon may vary depending on the projection used — it is 
important that you specify the projection correctly to ensure that area calculations used 
in KBA assessments are consistent.  

In this topic, we will take some time to demonstrate this point, by using various methods 
to calculate the area of the global range polygon for the Polar Bear. We provide two 
methods for calculating area correctly for the purposes of KBA assessment in QGIS — 
you may use whichever you prefer as the answer will be the same.  

We’ll also show you how to intersect a range polygon with a site polygon and calculate 
the area of the range that falls within the site. We’ll first demonstrate this using a non-
migratory species as an example, and then look at how to do this for a migratory species 
with multiple range polygons coded by season. 

A Polar Bear experiment to demonstrate the importance of projection 

As explained above, it’s important that any layers used for area calculations are based on 
the standard equal-area projection used in KBA analysis: the World Cylindrical Equal-
Area projection (i.e. ESRI: 54034). 

QGIS is a user-friendly GIS package that provides several methods for estimating the area 
of a polygon. It’s important that you use the correct method for KBA identification. If you 
don’t, the results may not match calculations from other GIS packages — the scale of the 
error will depend on the size of the area and its geographic location. Given that KBA 
assessment often relies on accurate estimation of the proportion of a species’ range or an 
ecosystem’s extent at a site, it’s essential that area calculations are accurate and consistent. 
We’ll demonstrate this issue with an experiment using the range map for the Polar Bear. 

Polar bear range map 

For the purposes of this exercise, we’ll use the IUCN Red List range map for the Polar 
Bear (Ursus maritimus, VU): 
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Go the IUCN Red List and search for “Polar Bear”, download the range data and 
add the Polar Bear range shapefile to your QGIS project as you did for the 
Whooping Crane. We recommend you save the Polar Bear data to a subfolder 
named “Ursus_maritimus” or similar 

The new layer is called “data_0”, so you might want to rename it as you did for 
the Whooping Crane 

Rough-and-ready area estimation: $area 

First we’ll estimate the area of the Polar Bear range using a rough-and-ready method for 
area estimation using unprojected spatial data. In this method, QGIS can estimate the 
area of an unprojected polygon (e.g., a polygon in EPSG:4326) by referring to the 
underlying ellipsoid (e.g., WGS 84). This method can produce good results, especially for 
small areas near the Equator, but it’s not reliable. 

Check the CRS by right-clicking on the Polar Bear layer, selecting Properties 
and then Source; you’ll see that the Assigned CRS is EPSG:4326 – WGS 84. This 
means that the spatial layer is the standard geographic coordinate system based 
on the WGS 84 ellipsoid and has not been projected. Close the Layer 
Properties box. 

Now open the Attribute Table, , for the Polar Bear layer 

Click on the button at the top to open the Field Calculator 

In the center box, select Geometry and then double-click on “$area” 

The area estimate will show in the lower-left by Preview: 22,634,789 (plus a few 
decimal places); the estimate will be in square kilometers if you set that as your 
Preferred area units earlier. 

Note down the area estimate somewhere handy for comparison and click Cancel; 
close the Attribute Table 

Reprojecting the spatial data layer 

Next we’ll reproject the Polar Bear range data in standard World Cylindrical Equal-Area 
projection and repeat the experiment. 
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Highlight the Polar Bear range layer in the Layers Panel on the left 

In the QGIS menu bar, select Vector > Data Management Tools > 
Reproject Layer 

In the Target CRS box, select Project CRS: ESRI; 54034 – 
World_Cylindrical_Equal_Area, and then click Run 

The new temporary layer will show up in the Layers Panel on the left, labelled 
Reprojected 

Now use the same rough-and-ready method as before to estimate the range area. The 
area estimate will be almost the same as the previous estimate because both estimates are 
based on the same underlying ellipsoid (i.e. WGS 84). 

Based on the experiment so far, it looks like it doesn’t really matter whether or not you 
reproject the data layer as the rough-and-ready estimates are almost the same, even for 
this large range area. The problem is that they are not accurate and a different GIS would 
calculate area differently.  

Correct area calculation based on the specified projection: area($geometry) 

Now let’s calculate area correctly, based on the specified projection: 

Open the Attribute Table for the reprojected Polar Bear layer again and then 
open the Field Calculator 

In the left box under Expression, copy-paste “area($geometry)/1000^2”; the 
1000^2 converts from m2 to km2 for comparison with our previous estimates 

The area calculation will show in the lower-left by Preview: 22,637,383 (plus a 
few decimal places) 

Note down the area calculation somewhere handy for comparison, click Cancel, 
and close the Attribute Table 

If you compare the new calculation with the rough-and-ready estimate, you’ll find a 
difference of some 2,500 km2! 

The correct method calculates the area based on the projection we specified. Essentially 
we use the projected CRS (in this case the World Cylindrical Equal-Area projection) to 
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tell QGIS exactly how we want to convert our 3-dimensional geographic data to a 2-
dimensional planimetric surface for the purposes of calculating area. 

Another user should get the same result for the same shapefile in the same projection in 
any other GIS.  

Correct area calculation using on-the-fly projection: area(transform($geometry, …, …) 

If the correct method summarised above seems rather cumbersome, QGIS has provided 
an alternative method for estimating area in a specified projection without creating a new 
projected shapefile: 

Right-click on the original spatial layer in the geographic CRS (i.e. EPSG:4326) and 
open the Attribute Table and then the Field Calculator 

Copy-paste “area(transform($geometry, 'EPSG:4326','ESRI:54034'))/(1000^2)” into 
the Expression box 

The new area calculation will be identical to the previous correct area calculation. The 
transform() function implements an on-the-fly projection (from EPSG:4326 to ESRI: 54034 
as specified). 

You can use either correct method to calculate area in QGIS for all KBA assessments, as 
they give the same results. We recommend the method based on on-the-fly projection as 
you don’t need to save a copy of each shapefile in a different projection.  

Technical Box: Recommended method for area calculation 

Copy-paste the following expression into the Expression box of the Field 
Calculator: 

area(transform($geometry, 'EPSG:4326','ESRI:54034'))/(1000^2) 

We’ll not return to the Polar Bear, so you can tidy up your Layers Panel by removing 
all Polar Bear layers. 

We recommend you Save your project now. 
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Estimating the size of WDPA sites 

The WDPA polygon shapefiles include a field named GIS_AREA, calculated in the 
Mollweide projection. This value will be very similar to the value calculated using the 
World Cylindrical Equal-Area projection using the correct method summarised above. 
Nevertheless, it is important to recalculate the area using the World Cylindrical Equal-
Area projection to ensure consistency across all sites. 

Estimating global range area 

For the next exercise, we’ll use the IUCN Red List range map for Marshall’s Pygmy 
Chameleon (Rhampholeon marshalli, VU). Follow the same steps as for the Whooping 
Crane and Polar Bear to download the range data from the IUCN Red List and import it 
to your QGIS project. As before, the shapefile is called “data_0”, so you might want 
to rename it to something more specific. If you change the Layer Styling to purple, it 
will look similar to the image below: 
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Use the correct method for area calculation using on-the-fly projection, as described 
above for the Polar Bear. 

Right-click on the chameleon spatial layer and open the Attribute Table. We 
only have one feature in this case, but it’s always good practice to check that the 
Presence, Origin and Season codes match your current task 

Open the Field Calculator, then copy-paste “area(transform($geometry, 
'EPSG:4326','ESRI:54034'))/(1000^2)” into the Expression box 

This time we’ll save the area calculation to a new field by typing “GLOB_AREA” 
in the Output field name box, selecting Decimal number (real) in the Output 
field type box, and setting Precision = 3, then selecting ok 
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The global range area calculation will now show up in the final column: 529.890 
km2 

Close the Attribute Table, then right-click and Save Layer Edits 

In this case, the total range area is slightly less than the estimated Area of Occupancy 
(AOO) given in the IUCN Red List account, possibly because AOO is calculated using 2 
x 2 km grid cells. 

Intersecting site and species range polygons to calculate the area within a site 

Intersect a species’ range with a KBA 

If only part of a species’ global range falls within a site, the first step to calculating the 
area of the range within the site is to create a new spatial layer based on the intersection 
of the species’ global range polygon(s) with the site polygon. We’ll save this layer as a 
shapefile so that it can be submitted as part of a KBA Proposal: 

In the QGIS menu bar, select Vector > Geoprocessing Tools > 
Intersection 

Set your chameleon layer as your Input layer and your site layer as your 
Overlay layer; you can use the Chimanimani layer you created earlier or the 
KBA layer for Mozambique if you have it  

Leave Input fields to keep blank, so that all fields from the species range 
data are retained 

Click on the … next to Overlay fields to keep, and select the SitRecID and 
NatName if you are using an existing KBA, or WDPA_PID, NAME and 
DESIG_ENG if you’re using a WDPA data layer (e.g., the Chimanimani layer you 
created earlier) plus any other fields you think would be useful and click ok 

Click the … next to Intersection, select Save to File … navigate to your 
chameleon subfolder and type in a name for your intersection shapefile, click 
Save, then Run1 

 
1 Occasionally the intersection process will produce an error message relating to invalid geometries. See 
the next section for guidance on how to resolve this type of error. 
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Your new shapefile will now show up in your Layers Panel — Zoom to Layer 
and you’ll see it comprises the segments of the range polygons that intersect the 
Chimanimani KBA as shown in the image below (zoomed in to the north of the 
KBA, with the global range polygons in purple and the range within the site in red 
hatch). 

 

Fixing geometries 

Occasionally the intersection process will produce an error message relating to invalid 
geometries. (This seems to be fairly common for shapefiles created in ArcGIS and 
imported to QGIS.) QGIS has built-in tools for detecting and fixing invalid geometries. 

For example, an attempt to intersect range polygons with the Malaysia KBA polygons (as 
at March 2021) produces the following error message: 

Feature (55) from “KBAsGlobal_2021_March_Malaysia” has invalid geometry. 
Please fix the geometry or change the Processing setting to the “Ignore invalid 
input features” option. 

To identify the problem, return to the main QGIS window and select Vector > 

Geometry Tools > Check Validity. Check that the layer with invalid geometries 
is shown under Input layer, then click on Run. 
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In the Layers panel, you will see 3 new layers. The Error output layer shows the 
locations and description of the geometry errors. Right-click and Zoom to layer to see 
the location; right-click and select Open Attribute Table to see a description of the 
error (e.g., ring self-intersection, where a polygon contains an interior hole, as in the 
example shown here). 

 

To fix the problem, select Processing > Toolbox, then search for “fix geometries” 
and select that option. 

In the Fix Geometries window, check that the original layer with invalid geometries 
(not the Error output) is shown under Input layer, then click on Run. In the 
Layers panel, you will see a new layer, Fixed Geometries, which resolves the geometry 
error without changing the KBA boundaries, as shown here. (The original KBA polygon 
is shown in green; the boundary of the fixed KBA polygon is shown as a dotted black 
line.) 
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Now, re-run the intersection process on the fixed layer and the invalid geometries error 
will be resolved. 

Calculate the area of the intersection 

Next open the Attribute Table for the new intersection layer 

Calculate the area as before, but this time use the Output field name 
“SITE_AREA” 

In the toolbar, click the  button to Save Layer Edits  

If you used the KBA layer, you’ll see the range area in the KBA is 105.934 km2 (i.e. 19.99% 
of the species’ global range). 

If you used the Chimanimani layer you created earlier, you’ll see the range area in the 
National Park is 55.214 km2and the range area in the Buffer Zone is 50.841 km2.  

Sum the area of multiple features 

While we could easily sum the range area within the National Park and the Buffer Zone 
on a calculator, QGIS also provides a convenient tool to do this. 

In the main toolbar, click the  button for Statistics; select the relevant species 
layer, then select the relevant Field name immediately below (e.g., SITE_AREA), and 
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you will see the sum of the area of all features in the row labelled Sum. In this case, we 
have 2 features (Count) and the total area is 106.055 km2 (Sum). This is slightly greater 
than for the KBA as there are minor differences in the boundaries. 

Estimating the range size of migratory species 

In the case of Marshall’s Pygmy Chameleon, we have a single feature, comprising 
multiple spatially distinct polygons, coded Presence = 1 (i.e. Extant); Origin = 1 (i.e. 
Native); and Seasonality = 1 (i.e. Resident). How would we adapt the process for 
estimating global or site-level range areas for migratory species with multiple features 
coded by season? 

For migratory species that have distinct breeding and non-breeding ranges identified in 
IUCN Red List range maps (i.e. separate polygons coded by season), the KBA Guidelines 
say that breeding and non-breeding ranges will typically be assessed separately.  

Let’s return to the Whooping Crane example. If you previously removed the crane layer, 
add it back to your QGIS project now. Then apply the same procedure as for the 
chameleon to calculate the area of each of the four features, but this time set the Output 
field name to “FEAT_AREA”. 

If you like, click on the  button to Dock Attribute Table — you’ll now see the 
Attribute Table below your map. You’ll notice that several of the features are 
overlapping. Consequently, if we simply summed the area for all four features, we would 
overestimate the combined spatial footprint. 

To calculate the global area of the breeding range: 

First check the Presence and Origin codes for all features, then select the relevant 
features that are coded Seasonal = 1 (i.e. Resident) or Seasonal = 2 (i.e. Breeding 
Season) 

Check that the selected polygons do not overlap (this can often be done visually, 
but see below for a more technical approach) 

In the main toolbar, click the  button for Statistics; select the relevant 
species layer, then select the relevant Field name immediately below (e.g., 
FEAT_AREA) 
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You’ll see the sum of the area of all features. In this case, the Count shows that we 
have 4 features, but we can check the Selected features only box to focus 
on the 2 features that comprise the breeding range: the sum of the area of selected 
features is 6,122.73 km2. 

To calculate the global area of the non-breeding range: 

Click on the  button to Deselect all features from the layer 

Select polygons coded Seasonal=1 (i.e. Resident) and Seasonal=3 (i.e. Non-
breeding) and check that the selected polygons do not overlap 

Use the Statistics tool, , to calculate the sum of the area of the selected 
features: 10,919.7 km2. 

Handling overlapping features when estimating range size 

The Topology Checker plugin can be useful for checking whether range polygons 
overlap without relying on visual inspection. 

In the QGIS menu bar, select Plugins > Manage and Install Plugins. 
Search for “Topology Checker” and make sure it’s checked.  

In the QGIS menu bar, select Vector > Topology Checker. Click on the  
button to configure. Under Current Rules, select the relevant species layer. In 
the next box, select the rule “must not overlap”. Click Add Rule, then click OK. 

Then click the  button in Topology Checker to Validate All. Any 
overlaps will show up as “errors” in the box below. Note, however, that these may 
include marginal overlaps between adjacent polygons.  

If there are overlaps between features that should be included in the same range size 
estimation (e.g., polygons coded as Seasonal = 1 (i.e. Resident) and Seasonal = 2 (i.e. 
Breeding Season)), the best approach is to Dissolve the relevant features into a single 
feature before calculating the area: 
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In the QGIS menu bar, select Vector > Geoprocessing Tools > Dissolve 
.... Select the relevant species layer, checking selected features if 
appropriate.  

You can leave the box under Dissolved as “[Create temporary layer]” or or click 
on the … to Save to File… 

Open the Attribute Table for the new Dissolved layer. Then calculate the 
area using the correct area calculation method with on-the-fly projection (i.e. by 
opening the field calculator and pasting “area(transform($geometry, 
'EPSG:4326','ESRI:54034'))/(1000^2)” into the Expression box). 

If you try this for the crane layer, the result will be 1544372.885, which is 
approximately the same as the sum of all 4 features (i.e. 1.54437e+06) as overlaps 
are marginal.  

Topic summary 

Well done — you’ve completed the topic on calculating area and values of area-based 
parameters.  

We recommend you Save your project now. 

In the next topic, we’ll look at ecosystem distribution data. 
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Topic 8: Working with ecosystem distribution data 

In this topic, we’ll focus on working with ecosystem distribution data. 

[This section will be completed in the next version of this Tutorial.] 

Download an ecosystem distribution map from the Red List of Ecosystems 

Estimating global ecosystem extent 

Intersecting site and ecosystem extent polygons to calculate the ecosystem 
extent within a site 

Intersect an ecosystem’s distribution with a KBA 

Calculate the area of the intersection 

Topic summary 

Well done — you’ve completed the topic on working with ecosystem distribution data. 

We recommend you Save your project now. 

In the next topic, we’ll look at GIS tools for delineating KBAs. 
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Topic 9: GIS tools for delineating KBAs 

This topic focuses on GIS tools and techniques for adjusting the boundaries of existing 
KBAs or delineating new KBAs. Please see the KBA Standard and KBA Guidelines for 
guidance on the principles that should be followed in KBA delineation. 

We’ll start by showing you where to find additional base maps that might be useful for 
KBA delineation. We’ll then show you how to digitise a new polygon or refine an existing 
polygon. We’ll also use this opportunity to show you how to dissolve multiple features 
(e.g., polygons) into a single feature (e.g., set of polygons with shared attributes). This 
can be useful if, for example, you digitise several spatially separate polygons representing 
the range of a species (with the same values for presence, origin and season). 

Additional base maps for delineating KBAs 

When working on KBA delineation, you may want to refer to additional base maps. You 
can access a wide variety of base maps through the QuickMapService plugin. 

First, load or update the plugin as follows: 

In the QGIS menu bar, select Plugins > Manage and Install Plugins 

Check Installed to see whether QuickMapServices is already installed and 
upgrade if a new version is available 

If QuickMapServices is not already installed, check Not installed and 
follow the instructions 

Next, search for additional base maps and add them to your project: 

In the QGIS menu bar, select Web > QuickMapService > Search QMS 

Try searching for “google satellite hybrid” or “google terrain hybrid” and adding 
those to your project 

To identify additional layers that are available for your country, zoom to your 
country and then click Filter by extent  

Basemaps for marine applications  

If you are working on marine KBAs, you will probably want to refer to a basemap that 
shows ocean bathymetry. After installing the QuickMapService plugin, as above: 
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In the QGIS menu bar, select Web > QuickMapService > Search QMS 

Search for “ocean” and add the ESRI ocean basemap to your project 

When delineating marine KBAs, it may be useful to reference bathymetric contours (i.e. 
contours indicating the depth of the sea floor). Bathymetry data can be downloaded from 
the General Bathymetric Chart of the Oceans (GEBCO) in various forms. Here we will 
demonstrate how to download bathymetric data for a specific area and display the data 
as bathymetric contours. 

On the GEBCO page for gridded bathymetry data, click on “download data for 
user-defined areas” and then “application” 

Select your region of interest on the map; in the panel on the left, select the latest 
version, and then check the box under GeoTIFF and Grid, then click on “Add to 
basket” and then “View basket”.  

Once your data have downloaded, navigate to the downloaded zipfile in your 
downloads folder, unzip it, and copy all the files to your spatial data folder 

In the QGIS menu bar, select Layer > Add Layer > Add Raster Layer, 
click on the … at the right of the Raster Datasets box and then navigate to your 
spatial data folder 

Select the “gebco .. “ file with “.tif” at the end and click Open 

Click Add then Close 

In the Layers Panel, highlight your new bathymetry layer and open the 

Layer Styling Panel,  

In the dropdown box at the top, select Contours 

The image below shows the ESRI ocean layer with GEBCO contours overlaid, revealing 
the complex bathymetry around New Zealand’s Kaikoura Canyon.  
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Note that the GEBCO datasets have traditionally focused on deeper waters (e.g., depths 
greater than 200 m), but work is ongoing to incorporate datasets for shallower waters (see 
here for details). In the meantime, you may need to reach out to your national 
hydrographic service to access bathymetric data for shallower waters in your region. 

Digitise a polygon and create a new spatial layer 

You may wish to delineate an entirely new site which requires a new polygon to be 
digitised. To do so, first make sure that the appropriate Layers Panel, Digitising 
Toolbar, Manage Layers Toolbar and Map Navigation Toolbar are displayed. 
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(Panels and Toolbars can be added or removed by right-clicking the grey panel above the 
base map.) 

In the Manage Layers Toolbar, click the New Shapefile Layer button, 

 

Your File name should be something useful (e.g., the proposed name for the 
new KBA). Click the … next to the File name field, navigate to the appropriate 
folder, and click Save 

Change Geometry type to Polygon 

By default, the CRS is set at EPSG:4326 – WGS 84. Once the new polygon layer has 
been created, it can be projected into World Cylindrical Equal-Area projection 
later, if necessary. 

Polygon attributes can be added within the New Field section and the Type 
specified as Text Data, Whole Number, Decimal Number, or Date. For each new 
field, type the Name, then select the appropriate Type, click Add to Fields 
List. After all fields have been added, click OK. (Please see the shapefile templates 
provided on the KBA website (on the Tools page) for standard Field Names and 
Types for KBA shapefiles.) 

Your new shapefile will now show up as a spatial layer in your Layers Panel.  

To draw the polygon: 

First make sure the new Layer is highlighted, then click the Toggle Editing 

button,  , followed by the Add Polygon Feature button,  

On your base map, select as many points as necessary to delineate an accurate and 
precise boundary. When satisfied with your boundary, right-click.  

In the pop-up window, fill in the Attributes for the new polygon. You can leave 
the id field as NULL or assign a name or number. Then click OK.  

In most scenarios, you will only create one polygon. However, if you are proposing a site 
that consists of more than one polygon: 

Assign a unique id to your initial polygon and click OK.  
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Then, draw a new polygon boundary, right-click, assign a unique id to the new 
polygon, then click OK. Repeat this process until all desired polygons have been 
delineated. 

Finally, click Save Layer Edits button, , to save your new polygon layer. 

You can practice by delineating polygons around lakes or islands, as shown in the image 
below. 

  

For large polygons, it will often make sense to delineate an initial polygon roughly at a 
relatively broad spatial resolution (e.g., 1:50000) and then refine it at a finer resolution 
(e.g., 1:15000). You can check the Scale at the bottom of your QGIS project window. 
See below for how to refine an existing polygon. 

Adjust or refine an existing polygon on-screen and create a new spatial layer 

When adjusting an existing polygon, we strongly recommend that you first save a copy 
of the existing polygon and edit that. 

Right-click on the target layer and select Export > Save Features As… to 
save the layer under a new name. The new layer will show up in your Layers 
Panel 
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Highlight the new layer, click the Toggle Editing button,  , then select the 

Vertex Tool (Current Layer), . Hover the cursor over the polygon to 
reveal the points used to delineate the existing polygon; click on a point then move 
the cursor to shift the point 

Note that you can add and remove points as part of this process. To create a 
smoother boundary, create a new point by clicking on the line midway between 
two existing points and then move the new point 

To remove a point, highlight the point and then press delete on your keyboard  

Repeat this process to redelinate the polygon, then click the Save Layer Edits 

button, , to save your new polygon. 

For example, we edited the polygon in the image above to include some of the sand bars. 
The image below shows both the original and edited polygons. 

 

Dissolve multiple features into a single feature 

In some cases, it may be useful to combine multiple polygons represented as different 
features into a single one. For example, it may be useful to dissolve different polygons 
representing  a species’ breeding or non-breeding range into a single feature. 
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On the QGIS menu bar, select   Vector > Geoprocessing Tools > 
Dissolve …  

A new window will open that will ask you to select which layer you wish to 
dissolve (i.e. the Input Layer), and which Dissolve fields to use. If the 
Dissolve field(s) box is left blank, all polygons in the layer will be merged 
into a single feature. Alternatively, if one or more fields are selected, by clicking 
on the … to the right of the Dissolve field(s) box, selecting one or more fields 
and then clicking ok, polygons with the same value for selected fields will be 
dissolved into a single feature.  

For example, we created a new layer representing the distribution of mature males and 
females of a fictitious sea lion species in the breeding and non-breeding season (left panel 
in image below; numbers refer to polygon ids). The layer comprises 3 polygons 
represented as separate features — the Attribute Table is shown below. 

 

Applying the Dissolve tool with Dissolve field(s) left blank, dissolves the 3 
polygons into a single feature. But, applying the Dissolve tool with “Breeding” 
selected as a Dissolve field, dissolves the 2 polygons coded Breeding = 0 into a single 
feature (shown in green in the right panel below), leaving the remaining polygon (coded 
Breeding = 1) as a separate feature. 
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Note that, when dissolving polygons, the attributes of one input polygon will be used to 
populate the attributes for the dissolved polygon. Please check the Attribute Table 
carefully to make sure that it accurately represents the attributes of dissolved polygons 
and edit as appropriate. (For example, in this case, the count for one of the two non-
breeding polygons is retained, so we must edit the attribute data (see below) to show the 
sum of the counts of the dissolved polygons instead.) 

Topic summary 

Well done — you’ve completed the topic on GIS tools for delineating new KBAs.  

We recommend you Save your project now. 

In the next topic, we’ll look at ways to edit attribute data. 
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Topic 10: Working with attribute data 

Shapefile templates will be provided on the KBA website (in the Tools section). You may 
need to add, rename or remove attribute Fields and/or modify Field data types to 
match the appropriate template. In this topic, we’ll show you how to do this. 

Adding and removing attribute fields 

To add an attribute Field to an existing spatial layer: 

Open the Attribute Table, , and click on the Toggle Editing button, 

 

Click on the New field button, , to add an attribute field and complete the 
information required in the Add Field window 

Click on the Save edits button, , to save your changes 

To remove an attribute Field from an existing spatial layer: 

Open the Attribute Table, , and click on the Toggle Editing button, 

 

Click on the Delete field button, , and select the field(s) you want to 
remove from the Delete Fields window 

Click on the Save edits button, , to save your changes 

Editing the properties of an existing attribute field 

To change the name or edit other properties of an attribute Field: 

Right-click on the target layer in the Layers Panel and select Properties, then 
click on Fields on the left of the Layer Properties window 

For example, the Fields for the fictitious sea lion species we created earlier look like 
this: 
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To change the name of an attribute Field: 

Click on the Toggle Editing button, , and type in the new name for the 
attribute  

Click on the Toggle Editing button, , again and save your changes and 
then close the Layer Properties window  

To change data type, open the Refactor fields tool: 

Click on the Processing Toolbox button, , in the menu bar and type 
“refactor” in the search box to find the Refactor fields tool 

Double-click on Refactor fields to open a pop-up window, select the target 
layer in the Input layer box, and then use the drop-down options in the 
Fields mapping window to change field types (see example below). (When 
changing from a Whole number to a Decimal number, you will also need to 
increase the Precision to the number of decimal places required.) 
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Leave the Refactored box blank to create a temporary layer or click on the … to 
Save to File… 

Select Run, then Close 

For example, we revised the attribute field properties for our fictitious sea lion, renaming 
the “Count” field to “Estimate” and changed the field type from Whole number to 
Decimal number with Precision = 3 (see below): 

 

Edit attribute data 

To edit attribute data in an existing Field: 

Open the Attribute Table, , and click on the Toggle Editing button, 

 

Edit the data as required 
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Click on the Save edits button, , to save your changes 

Topic summary 

Well done — you’ve completed the topic on working with attribute data.  

We recommend you Save your project now. 

In the next topic, we’ll show you how to prepare KBA shapefiles for submission.  
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Topic 11: Preparing KBA shapefiles for submission 

In this final topic, we’ll show you how to export a spatial layer from QGIS as a ESRI 
shapefile so that it can be submitted as part of a KBA Proposal. 

Specifications for KBA shapefiles 

KBA boundaries and spatial data on the distribution of trigger biodiversity elements 
within a KBA must be provided as ESRI shapefiles.  

Shapefiles must be provided in the standard geographic CRS and datum: latitude and 
longitude (decimal degrees) combined with the WGS 84 datum (i.e. EPSG 4326 in QGIS 
or “GCS_WGS_1984” in ArcGIS).  

Technical Box: CRS for KBA shapefiles 

Shapefiles must be provided in the standard geographic CRS and datum: 
 

latitude and longitude (decimal degrees) and WGS 84 
 
(i.e. EPSG 4326 in QGIS or “GCS_WGS_1984” in ArcGIS) 

Shapefiles should follow a set format with specific attributes Shapefile templates will be 
provided on the KBA website (in the Tools section).  

Please see the KBA Proposal Process guidance document (Annex B) for the complete KBA 
mapping standards. 

Export a spatial layer as an ESRI shapefile  

In the Layers Panel, right-click on the target layer, select Export, then Save 
Features As ...  

Make sure the Format box shows “ESRI shapefile”  

Make sure the CRS box says EPSG:4326 – WGS 84 

Click on the … to the right of the File name box and navigate to your spatial 
data folder 

Follow the file name and other requirements in the KBA Proposal Process 
guidance document (Annex B) 
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Then click ok 
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Contributors 

Charlotte Boyd, Daniele Baisero, David Díaz, Andrew Plumptre, Andrew Snyder, 
Stephanie Todd, Marcelo Tognelli 

Updates and Feedback 

This tutorial will be updated periodically.  

We would welcome user feedback and additional material, including step-by-step 
instructions for additional tasks relevant to KBA identification and delineation.  

Please email Andrew Snyder (asnyder@rewild.org) if you have comments or suggestions 
or would like to contribute to this tutorial. 

Summary of changes 

Version 1.2 (November 2021) 

Topic 1: New recommendation on checking for projection errors in imported shapefiles 

Topic 7: New section on fixing geometries 

Appendix I: New appendix with step-by-step guidance on compiling site-species tables 
from IUCN Red List data  

Version 1.1 (September 2021) 

Topics 3-10: introductory sections added. 

Version 1.0 (August 2021) 
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Appendix I: Suggested workflow for compiling site-species 
tables from IUCN Red List data 

This appendix provides a suggested workflow for compiling site-species tables from 
IUCN Red List range data as part of an initial scoping analysis. There are many ways to 
perform this task. The step-by-step guidance below is intended to provide a starting point 
for those with limited previous familiarity with GIS. The process may be readily adapted 
for ecosystem datasets. 

For the purposes of demonstration, we will create a site-species table for existing KBAs 
in the Malaysia (as at March 2021) and amphibians endemic to Malaysia, but the steps 
will be similar for any country and taxonomic group. The final site-species table may look 
like this: 

 

Species data 
On the IUCN Red List website (www.redlist.org), click on Login/Register in the top 
menu to set up a free account if you don’t have one already, and log in. 

Click on Advanced next to the search bar to use the advanced search function to select 
the dataset you are interested in. For example, select the following for amphibians 
endemic to Malaysia: 

Taxonomy > Animalia > Chordata > Amphibia – add a check mark next 
to Amphibia 

and 

Land Regions > South and Southeast Asia > Malaysia – add a check 
mark next to Malaysia 

and 

Endemic – add a check mark next to Endemic 
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If you selected these options, you should have 86 species (as at November 2021): 

 

Click on the Download button and download the Results and Range data, as 
shapefiles (SHP) and points (CSV). (Points will be empty for most taxonomic groups 
other than plants.)2 

Navigate to the downloaded Results zipfile in your downloads folder and unzip it. Open 
the taxonomy.csv and assessment.csv files in Excel.  

In the taxonomy.csv file, delete the following columns: genusName, speciesName, 
infraType, infraName, infraAuthority, subpopulationName, authority, 
taxonomicNotes. 

In the assessment.csv file, check whether any of the species are considered Possibly 
Extinct or Possibly Extinct in the Wild. You can do this easily by selecting the top row of 
your spreadsheet, selecting Data > Filter from the top menu and then using the filter 
function to check whether any cells in the columns headed possiblyExtinct or 
possiblyExtinctInTheWild say “TRUE”. If so, add this information into the relevant 
cell of the column headed redlistCategory (e.g., as “Critically Endangered (Possibly 
Extinct)”).  

If you like, you may also abbreviate the information in the column headed 
redlistCategory (e.g., change “Endangered” to “EN”). (Hint: Change the label in the 
first cell, then highlight the cell and drag down from the bottom-right corner of the cell 

 
2 Note that you will need an IUCN Red List account to complete this step. KBA scoping analysis qualifies 
as research. 
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to change the label in all filtered cells.) You may also delete the information in the column 
headed redlistCriteria for Near Threatened species. 

Next, add the following columns from the assessment table to the taxonomy table: 
scientificName, redlistCategory, redlistCriteria. The order of species in 
the two tables should be identical, so you can simply use copy-paste, but it’s good practice 
to double-check whether two tables align when merging them in this way. You can do 
this by adding the following formula into a column to the right and then checking that 
the results sum to 0 over all rows: 

=IF(A2=I2, 0, 1) 

where A1 is the first cell in the column headed scientificName in the taxonomy 
table and I1 is the first cell in the column headed scientificName in the data copied 
from the assessment table. This formula will produce a “0” if the two cells match, and 
a “1” otherwise. Once you have checked that the data align, you can delete the second 
column headed scientificName. 

Add in a new column headed taxonomicGroup after scientificName. For each 
species, identify the appropriate taxonomic group for applying Criteria B2 and B3 (e.g., 
AMPHIBIA for amphibians) based on information provided in the restricted-range 
species spreadsheet on the KBA website (Tools page). It is worth noting down the 
Criterion B2 species threshold for each taxonomic group at the same time (e.g., this will 
be 2 species for most taxonomic groups). Once you’ve done this, you can delete the 
columns headed: kingdomName, phylumName, className, orderName, and 
familyName. 

The resulting table should have the following columns: 
• internalTaxonId3 
• scientificName 
• taxonomicGroup 
• redlistCategory 
• redlistCriteria 

Save the species table as a *.csv file with a new name (e.g., “taxon_assessment.csv”). 

 
3 This taxonomic ID will be used when submitting a KBA Proposal. 
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Spatial data 

Set up a QGIS project with your preferred base map and KBA shapefiles for your country, 
following the steps outlined in Topic 4. The KBA shapefiles are updated periodically, so 
check that you have the current dataset.4 

Range data (polygons): 

Navigate to the downloaded Range data (polygons) zipfile in your downloads folder and 
unzip it. Copy all the files to your spatial data folder — we recommend you save the data 
to a subfolder with a suitable descriptive name (e.g., “Malaysia endemic amphibians”). 
Import the shapefiles to your QGIS project following the steps outlined in Topic 6. 

Open the attribute table for the range polygons and use the select features using 

an expression function, , to select the appropriate range polygons in terms of 
presence, origin and season (see Topic 6 for more detailed explanation). You can check 
the range of values for presence in your polygon dataset by selecting Fields and 

Values > PRESENCE in the central panel, then double-clicking on All Unique in the 
right panel. Repeat for ORIGIN. Then select the appropriate range polygons by copy-
pasting the following into the Expression panel on the left:  

(“PRESENCE” < 3) and (“ORIGIN” <3 or “ORIGIN” = 6) 

This formula will select only those polygons coded 1 (Extant) or 2 (Probably Extant) for 
PRESENCE and 1 (Native) or 2 (Reintroduced) or 6 (Assisted Colonisation) for ORIGIN. 
Also check SEASON and determine how to handle migratory species (see the KBA 
Guidelines Appendix III for more guidance).  

Save the results for resident species as a new shapefile, with separate shapefiles for the 
breeding and non-breeding ranges of migratory species if you decide to treat these 
separately. The rest of this appendix will focus on resident species, but the steps are 
essentially the same for the breeding and non-breeding ranges of migratory species. 

Intersect range polygons with KBA polygons: 

Intersect the new range polygon shapefile with the KBA polygons, following the steps 
outlined in Topic 7, and save the results as a new shapefile. 

 
4 On the KBA website (Explore Data page), check that the date given on the Dashboard (e.g., “Dashboard 
(2021 – 03)” matches the name of your KBA shapefiles. 
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Area calculation: 

Calculate the size of each range polygon and add it to the shapefile as a new attribute 
(e.g., “feat_area”), following the steps outlined in Topic 7. We recommend that you use 
the correct area calculation method using on-the-fly projection based on the formula: 

area(transform($geometry,'EPSG:4326','ESRI:54034'))/(1000^2) 

Save the attribute table. 

Calculate the size of each intersected range polygon and add it to the shapefile as a new 
attribute (e.g., “inter_area”), using the same method. Save the attribute table. 

Create a global range size table: 

If you have multiple features per species (e.g., because some polygons are coded 
PRESENCE = 1 and others PRESENCE = 2), you will want to sum the area of the features 
(e.g., “feat_area”) to calculate the global range size for each species. 

Install the groupstats plugin if necessary by selecting Plugins > Manage and 

Install Plugins from the main menu, then searching for “group stats”. Select Group 
Stats and install it, if it is not installed already.  

Once installed, click on the Group Stats icon, . 

Select the appropriate range polygon layer in the Layers box.  

From Fields, drag “BINOMIAL” to Rows; drag “feat_area” to Values; drag 
“sum” to Values. 

Click on Calculate. 

From the top menu, select Data > Copy all to clipboard, then paste the 
results into an Excel spreadsheet. Change the heading “none” to globalValue, 
then save the spreadsheet as a *.csv file with a new name (e.g., 
“global_ranges.csv”). (This approach works better than saving the data as a *.csv 
file directly.) 
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Create a site range size table: 

Similarly, if you have multiple features per species (e.g., because some polygons are 
coded PRESENCE = 1 and others PRESENCE = 2), you will want to sum the area of the 
features (e.g., “inter_area”) to calculate the total area of the range polygons that fall within 
each site for each species. 

Select the intersected range polygon layer in the Layers box.  

From Fields, drag “SitRecId” to Rows; drag “IntName” to Rows; drag 
“BINOMIAL” to Rows; drag “inter_area” to Values; drag “sum” to Values. 

Click on Calculate. 

From the top menu, select Data > Copy all to clipboard, then paste the 
results into an Excel spreadsheet. Change the heading “none” to siteValue, then 
save the spreadsheet as a *.csv file with a new name (e.g., “site_ranges.csv”). 
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Join the taxonomy, assessment, global range and site range size data: 

Finally, you will want to join the taxonomy, assessment, global range and site range size 
data into a single site-species table. This can be done more easily in QGIS than Excel. 

Start by importing the taxon_assessment.csv, global_ranges.csv, and 
site_ranges.csv files into QGIS: 

From the top menu in QGIS, select Layer > Add Layer > Add Delimited 
Text Layer 

Click on the … next to the File name box and navigate to the 
taxon_assessment.csv file 

In the Data Source Manager window, select No geometry (attribute 
only table) 

Click on Add 

Repeat this process for the other two files, then click on Close 
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In your Layers panel: 

Right-click on site_ranges, then select Properties > Joins  

Click on the  icon and complete the Add Vector Join window as follows: 

Join layer: taxon_assessment 

Join field: scientificName 

Target field: BINOMIAL 

Click on OK 

Highlight Join layer in the window, click on the  icon again, and repeat 
the process for global ranges: 

Join layer: global_ranges 

Join field: BINOMIAL 

Target field: BINOMIAL 

Click on OK and then OK again 

In your Layers panel, right-click on the site_ranges layer and open the Attribute 
Table. Check that the number of rows is the same as in the saved site_ranges.csv 
file and that the attribute table now includes information on the taxonomy and IUCN Red 
List assessment for each species and the global range size. Close the Attribute Table. 

Export the new site_ranges layer by right-clicking and selecting Export > Save 
Features As, then choosing Format: Comma Separated Value [CSV] and a new 
file name (e.g., “taxon_assessment_site_global”). 

Final site-species data table: 

Finally, open the taxon_assessment_site_global.csv file in Excel and reorganise 
and rename columns as you wish.  

Add in four new columns headed: Apply KBA A1cd? restrictedRange, 
assessmentParameter, and sitePercent. 
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Leave the Apply KBA A1cd? for now – this can be completed during the assessment 
process. 

Check the threshold for restricted range size for the taxonomic group in the KBA Proposal 
form (Notes tab) and then add a “yes” in the restrictedRange column for restricted-
range species.  

For example, the threshold is 10,000 km2 for amphibians. Select the top row of your 
spreadsheet, then Data > Filter from the top menu, and then use the filter function 
to filter all species with global range size less than or equal to 10,000. Add a “yes” in the 
restrictedRange column for the filtered species. 

 

Complete the assessmentParameter column by inserting “range” in all cells. 

Complete the sitePercent column by calculating the percentage of the global range 
that falls within the site for each species-site combination. 

The final data table might have the following fields (or similar): 
• SitRecID 
• IntName 
• taxonId 
• scientificName 
• taxonomicGroup 
• redlistCategory 
• redlistCriteria 
• Apply KBA A1cd? 
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• restrictedRange 
• assessmentParameter 
• globalValue 
• siteValue 
• sitePercent 

Save the spreadsheet as an Excel workbook with a new name (e.g., “Malaysia endemic 
amphibians site-species table”). 

Final note: 

It is often useful to check whether any species in a taxonomic group have no valid range 
polygons and whether the ranges of any species do not overlap any sites. You can do this 
easily by adapting the process for joining tables above.  

To identify species without any valid range polygons, start with the 
taxon_assessment layer (which includes all species in the taxonomic group) and then 
join the global_ranges layer. Any species without valid range polygons will have 
“NULL” in the global range size column of the Attribute Table. Check the IUCN 
Red List account for any species that lack valid range data to find out more.5 

To identify species that do not have valid ranges overlapping sites, start with the 
taxon_assessment layer (which includes all species in the taxonomic group) and then 
join the site_ranges layer. Any species without valid range polygons will have 
“NULL” in the site range size column of the Attribute Table. 

 
5 For example, in the case of the Malaysia endemic amphibians, three species lack valid range polygons (as 
at November 2021): two species are listed as Data Deficient and have not been mapped; but one (Ansonia 
guibei) is Critically Endangered, with all range polygons categorized as Possibly Extinct or Presence 
Uncertain. This species would likely trigger a KBA under subcriterion A1e in the site where it is most likely 
to occur if it still exists (see the KBA Guidelines Section 2.4.1 for more details). 


